blob: 2a0188649c9fc647537b60719ea62644323a06f7 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Unicode Character Database"
2HOMEPAGE = "https://unicode.org/ucd/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/license.html;beginline=43;endline=83;md5=cf6c4777b109bcee78b6083a21be6192"
5
6SRC_URI = " \
7 https://www.unicode.org/Public/zipped/${PV}/UCD.zip;name=ucd;subdir=ucd \
8 https://www.unicode.org/license.html;name=license \
9"
10SRC_URI[ucd.sha256sum] = "033a5276b5d7af8844589f8e3482f3977a8385e71d107d375055465178c23600"
11SRC_URI[license.sha256sum] = "e415e1f2188ef2b1a5f7e6ee8c60cefe8a49dacd8b96c9025cad5013985129e4"
12
13inherit allarch
14
15do_configure[noexec] = "1"
16
17do_install() {
18 install -d ${D}${datadir}/unicode
19 cp -rf ${WORKDIR}/ucd ${D}${datadir}/unicode
20}
21
22FILES:${PN} = "${datadir}/unicode/ucd"