blob: 55b889099746553445351b931444dda82e4a747f [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
13
14SRC_URI[sha256sum] = "3891b1df82369acbc8451d4952cd20755f49a82398dce62437511ad17b47290e"
15
16RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
17
18BBCLASSEXTEND = "native nativesdk"
19
20# Needs abseil-cpp which does not build for ppc64le/musl
21COMPATIBLE_HOST:libc-musl:powerpc64le = "null"
22