blob: c5d05a8dad80d220efd2bbfe18850993c459c783 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
6
7PYPI_PACKAGE = "ipython"
8
9SRC_URI[sha256sum] = "2097be5c814d1b974aea57673176a924c4c8c9583890e7a5f082f547b9975b11"
10
11RDEPENDS:${PN} = "\
12 ${PYTHON_PN}-setuptools \
13 ${PYTHON_PN}-jedi \
14 ${PYTHON_PN}-decorator \
15 ${PYTHON_PN}-pickleshare \
16 ${PYTHON_PN}-traitlets \
17 ${PYTHON_PN}-prompt-toolkit \
18 ${PYTHON_PN}-pygments \
19 ${PYTHON_PN}-backcall \
20 ${PYTHON_PN}-pydoc \
21 ${PYTHON_PN}-debugger \
22 ${PYTHON_PN}-pexpect \
23 ${PYTHON_PN}-unixadmin \
24 ${PYTHON_PN}-misc \
25 ${PYTHON_PN}-sqlite3 \
26"
27
28inherit setuptools3 pypi