blob: a4ec62626bcc1c51e5d47c0d60d93b3139388ff4 [file] [log] [blame]
William A. Kennington III49e95662021-09-15 16:19:36 -07001SUMMARY = "Open source Python library for rapid development of applications \
2 that make use of innovative user interfaces, such as multi-touch apps."
3HOMEPAGE = "https://kivy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f0c851d60495c7e27225a819e179208a"
6
7inherit setuptools3 pkgconfig features_check
8
9SRC_URI = "\
10 git://github.com/kivy/kivy.git;protocol=git;\
11"
12
13# Kivy's setup files only look for GLES libraries for Android, iOS, RPi,
14# and mali-based OS's. We need to patch the setup file to tell Kivy setup
15# that our machine has GLES libaries installed as well
16# Also, if using SDL2 as backend, SDL2 needs to be configured wth gles
17SRC_URI += " \
18 file://0001-add-support-for-glesv2.patch \
19"
20SRCREV = "dedcb6bcabe3d8d6758dcee607e8c33b174d782b"
21
22S = "${WORKDIR}/git"
23
24PACKAGES += "${PN}-examples"
25FILES:${PN}-examples = "/usr/share/kivy-examples"
26
27USE_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '1', '0', d)}"
28export USE_WAYLAND
29
30# if using Wayland, let's use pure Wayland (and not XWayland)
31# so do not build using X11 flag when we detect Wayland
32USE_X11 = " \
33 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '0', \
34 bb.utils.contains('DISTRO_FEATURES', 'x11', '1', \
35 '0', d), d)}"
36export USE_X11
37
38# Use OpenGL ES 2.0 library
39KIVY_GRAPHICS = "gles"
40export KIVY_GRAPHICS
41
42KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}"
43export KIVY_CROSS_SYSROOT
44
45REQUIRED_DISTRO_FEATURES += "x11 opengl"
46
47DEPENDS += " \
48 gstreamer1.0 \
49 gstreamer1.0-python \
50 libsdl2 \
51 libsdl2-ttf \
52 libsdl2-image \
53 libsdl2-mixer \
54 pango \
55 python3 \
56 python3-cython-native \
57"
58
Andrew Geisslereff27472021-10-29 15:35:00 -050059RDEPENDS:${PN} = " \
William A. Kennington III49e95662021-09-15 16:19:36 -070060 gstreamer1.0 \
61 gstreamer1.0-python \
62 libsdl2 \
63 libsdl2-ttf \
64 libsdl2-image \
65 libsdl2-mixer \
66 pango \
67 python3 \
68 python3-docutils \
69 python3-fcntl \
70 python3-image \
71 python3-pillow \
72 python3-pygments \
73"