blob: 2377bd5258538fd3d5e58a628acc6381a5c71ba9 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queues) for Python"
2HOMEPAGE = "http://semanchuk.com/philip/posix_ipc/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc089fb2f37e90799a54c19a20c9880f"
6
7PYPI_PACKAGE = "posix_ipc"
8
9# Archived version so we need to overwrite what the pypi class will derive
10PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "8c9443859492ecf3aae9182aa6b5c78c"
13SRC_URI[sha256sum] = "6cddb1ce2cf4aae383f2a0079c26c69bee257fe2720f372201ef047f8ceb8b97"
14
15inherit setuptools3 pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 ${PYTHON_PN}-pip \
21 "
22
23# RDEPENDS:default:
24RDEPENDS:${PN} += " \
25 "