blob: 8ae9ac996d650a93f476e55552077e1cc076bc2b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
2DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
3SECTION = "devel/python"
4HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \
7 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
9
10SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=master"
11SRCREV = "6d5f47ee8e8a36140b52bf52fe954a131a0aa5dd"
12
13S = "${WORKDIR}/git"
14
15# Same restriction as gtk+
16inherit features_check
17ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
18
19inherit pkgconfig autotools python3native
20
21FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"