blob: 0c3de5da795742378f7abc6be27202dcb4287626 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
14PYPI_PACKAGE_EXT = "zip"
15
16SRC_URI[sha256sum] = "7ea2454b847cfcb211e2906743c5c4a868ab096ab4ce1547ab102d91fb224443"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-threading \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-docutils \
26 ${PYTHON_PN}-ctypes \
27 ${PYTHON_PN}-logging \
28 ${PYTHON_PN}-numbers \
29 ${PYTHON_PN}-profile \
30"