blob: 3dbfe44faa24605d9341cb21d76c62e11ebe22b3 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
6
7SRC_URI[sha256sum] = "fffe509f556861c7343c6cba57ed05fe7bcf4b48a934a5b946ccb45428cf8883"
8
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
16
17RDEPENDS:${PN} += "\
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-numbers \
20"
21
22RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-json \
24 ${PYTHON_PN}-pytest \
25 ${PYTHON_PN}-pytz \
26"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/tests
30 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
31}
32
33BBCLASSEXTEND = "native nativesdk"