blob: eaf8bda846a0ea7aac836f85ddf8153c49b0908c [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# This recipe is originally from meta-openstack:
2# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python3-uritemplate_3.0.0.bb?h=master
3
4SUMMARY = "Simple python library to deal with URI Templates."
5AUTHOR = "Ian Cordasco"
6LICENSE = "Apache-2.0 | BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0f6d769bdcfacac3c1a1ffa568937fe0"
8
9SRC_URI[sha256sum] = "4346edfc5c3b79f694bccd6d6099a322bbeb628dbf2cd86eea55a456ce5124f0"
10
11inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"