blob: 4c221cc41f317957bba8ca2cab0dcc4f3d918b45 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "The Swiss Army knife of Python web development"
2DESCRIPTION = "\
3Werkzeug started as simple collection of various utilities for WSGI \
4applications and has become one of the most advanced WSGI utility modules. \
5It includes a powerful debugger, full featured request and response objects, \
6HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
7cookie handling, file uploads, a powerful URL routing system and a bunch \
8of community contributed addon modules."
9HOMEPAGE = "http://werkzeug.pocoo.org/"
10LICENSE = "BSD-3-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
12
13PYPI_PACKAGE = "Werkzeug"
14
15SRC_URI[sha256sum] = "aa2bb6fc8dee8d6c504c0ac1e7f5f7dc5810a9903e793b6f715a9f015bdadb9a"
16
17inherit pypi setuptools3
18
19CLEANBROKEN = "1"
20
21RDEPENDS:${PN} += " \
22 ${PYTHON_PN}-datetime \
23 ${PYTHON_PN}-difflib \
24 ${PYTHON_PN}-email \
25 ${PYTHON_PN}-html \
26 ${PYTHON_PN}-io \
27 ${PYTHON_PN}-json \
28 ${PYTHON_PN}-logging \
29 ${PYTHON_PN}-netclient \
30 ${PYTHON_PN}-netserver \
31 ${PYTHON_PN}-numbers \
32 ${PYTHON_PN}-pkgutil \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-simplejson \
35 ${PYTHON_PN}-threading \
36 ${PYTHON_PN}-unixadmin \
37 ${PYTHON_PN}-misc \
38 ${PYTHON_PN}-profile \
39"