blob: aeb27cef42e33188d18101a7ec8297c7b8a2760b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python 2 and 3 compatibility library"
2HOMEPAGE = "https://xlsxwriter.readthedocs.io"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e95e368cd6cb090815046688e92d11e"
6
7inherit pypi setuptools3
8
9PYPI_PACKAGE = "XlsxWriter"
10
11RDEPENDS:${PN} += " \
12 python3-crypt \
13 python3-datetime \
14 python3-compression \
15 python3-numbers \
16 python3-io \
17"
18
19SRC_URI[sha256sum] = "3f39bf581c55f3ad1438bc170d7f4c4649cee8b6b7a80d21f79508118eeea52a"
20
21BBCLASSEXTEND = "native nativesdk"