blob: 580ae7e89a3a5aefdb54c8837a11102b8668b368 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119"
4
5DEPENDS = "php re2c-native"
6
7SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
8
9SRC_URI[sha256sum] = "9be3ae0fdb4dc4a4c68084626cddc56f12396487e309a8c8dd318f0f900d1a68"
10
11UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz"
12
13inherit autotools
14
15EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
16
17do_configure() {
18 cd ${S}
19 ${STAGING_BINDIR_CROSS}/phpize
20 cd ${B}
21
22 # Running autoreconf as autotools_do_configure would do here
23 # breaks the libtool configuration resulting in a failure later
24 # in do_compile. It's possible this may be fixable, however the
25 # easiest course of action for the moment is to avoid doing that.
26 oe_runconf
27}
28
29do_install() {
30 oe_runmake install INSTALL_ROOT=${D}
31}
32
33FILES:${PN} += "${libdir}/php*/extensions/*/*.so"
34FILES:${PN}-dbg += "${libdir}/php*/extensions/*/.debug"