blob: 4007a4bd2d7b8480c7266997cc4615a04b90695f [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d148485768fe85b9f1072b186a7e9b4d"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://dhcpcd.service \
17 file://dhcpcd@.service \
18 "
19
20SRC_URI[sha256sum] = "819357634efed1ea5cf44ec01b24d3d3f8852fec8b4249925dcc5667c54e376c"
21
22inherit pkgconfig autotools-brokensep systemd useradd
23
24SYSTEMD_SERVICE:${PN} = "dhcpcd.service"
25
26PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27
28PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
30# ntp conflicts with chrony
31PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
32PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
33PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
34
35EXTRA_OECONF = "--enable-ipv4 \
36 --dbdir=${localstatedir}/lib/${BPN} \
37 --sbindir=${base_sbindir} \
38 --runstatedir=/run \
39 --enable-privsep \
40 --privsepuser=dhcpcd \
41 --with-hooks \
42 --with-eghooks \
43 "
44
45USERADD_PACKAGES = "${PN}"
46USERADD_PARAM:${PN} = "--system -d ${localstatedir}/lib/${BPN} -M -s /bin/false -U dhcpcd"
47
48do_install:append () {
49 # install systemd unit files
50 install -d ${D}${systemd_system_unitdir}
51 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir}
52
53 chmod 700 ${D}${localstatedir}/lib/${BPN}
54 chown dhcpcd:dhcpcd ${D}${localstatedir}/lib/${BPN}
55}
56
57FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"