blob: ffe4ef35236c32f5dd66ddc48a03600711e0202f [file] [log] [blame]
Andrew Geisslerd25ed322020-06-27 00:28:28 -05001# This recipe builds a native Go (written in Go) by first building an old Go 1.4
2# (written in C). However this old Go does not support all hosts platforms.
3
Brad Bishop19323692019-04-05 15:28:33 -04004require go-${PV}.inc
Andrew Geisslerd25ed322020-06-27 00:28:28 -05005
6inherit native
7
Patrick Williams213cb262021-08-07 19:21:33 -05008SRC_URI:append = " https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz;name=bootstrap;subdir=go1.4"
Andrew Geisslerd25ed322020-06-27 00:28:28 -05009SRC_URI[bootstrap.sha256sum] = "f4ff5b5eb3a3cae1c993723f3eab519c5bae18866b5e5f96fe1102f0cb5c3e52"
10
11export GOOS = "${BUILD_GOOS}"
12export GOARCH = "${BUILD_GOARCH}"
13CC = "${@d.getVar('BUILD_CC').strip()}"
14
15GOMAKEARGS ?= "--no-banner"
16
17do_configure() {
18 cd ${WORKDIR}/go1.4/go/src
19 CGO_ENABLED=0 GOROOT=${WORKDIR}/go1.4/go ./make.bash
20}
21
22do_compile() {
23 export GOROOT_FINAL="${libdir_native}/go"
24 export GOROOT_BOOTSTRAP="${WORKDIR}/go1.4/go"
25
26 cd src
27 ./make.bash ${GOMAKEARGS}
28 cd ${B}
29}
30do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin"
31do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin"
32
33make_wrapper() {
34 rm -f ${D}${bindir}/$2$3
35 cat <<END >${D}${bindir}/$2$3
36#!/bin/bash
37here=\`dirname \$0\`
38export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
39\$here/../lib/go/bin/$1 "\$@"
40END
41 chmod +x ${D}${bindir}/$2
42}
43
44do_install() {
45 install -d ${D}${libdir}/go
46 cp --preserve=mode,timestamps -R ${B}/pkg ${D}${libdir}/go/
47 install -d ${D}${libdir}/go/src
48 (cd ${S}/src; for d in *; do \
49 [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go/src/; \
50 done)
51 find ${D}${libdir}/go/src -depth -type d -name testdata -exec rm -rf {} \;
52 install -d ${D}${bindir} ${D}${libdir}/go/bin
53 for f in ${B}/bin/*
54 do
55 base=`basename $f`
56 install -m755 $f ${D}${libdir}/go/bin
57 make_wrapper $base $base
58 done
59}