blob: 78f2002040b59d1a18b13b4b26484d34b59ee20c [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Library providing simplified C and Python API to libsolv"
2HOMEPAGE = "https://github.com/rpm-software-management/libdnf"
3DESCRIPTION = "This library provides a high level package-manager. It's core library of dnf, PackageKit and rpm-ostree. It's replacement for deprecated hawkey library which it contains inside and uses librepo under the hood."
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
7SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master \
8 file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \
9 file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \
10 file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
11 file://0001-Add-WITH_TESTS-option.patch \
12 file://0001-Look-fo-sphinx-only-if-documentation-is-actually-ena.patch \
13 file://enable_test_data_dir_set.patch \
14 file://0001-drop-FindPythonInstDir.cmake.patch \
15 file://0001-libdnf-dnf-context.cpp-do-not-try-to-access-BDB-data.patch \
16 "
17
18SRCREV = "cee3e1c59f849d9be1bb8d7db3090cea5c59f4b6"
19UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(?!4\.90)\d+(\.\d+)+)"
20
21S = "${WORKDIR}/git"
22
23DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd json-c swig-native"
24
25inherit gtk-doc gobject-introspection cmake pkgconfig distutils3-base
26
27EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \
28 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \
29 -DWITH_TESTS=OFF \
30 -DWITH_ZCHUNK=OFF \
31 -DWITH_HTML=OFF \
32 "
33EXTRA_OECMAKE:append:class-native = " -DWITH_GIR=OFF"
34EXTRA_OECMAKE:append:class-nativesdk = " -DWITH_GIR=OFF"
35
36BBCLASSEXTEND = "native nativesdk"
37PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
38