blob: 0224744fe7a10c5ef52a9ead9558e81dee92fa40 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001DESCRIPTION = "Lua is a powerful light-weight programming language designed \
2for extending applications."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=307;endline=330;md5=79c3f6b19ad05efe24c1681f025026bb"
5HOMEPAGE = "http://www.lua.org/"
6
7SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
8 file://lua.pc.in \
9 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest file://run-ptest ', '', d)} \
10 "
11
12# if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release.
13PV_testsuites = "5.4.3"
14
15SRC_URI[tarballsrc.sha256sum] = "f8612276169e3bfcbcfb8f226195bfc6e466fe13042f1076cbde92b7ec96bbfb"
16SRC_URI[tarballtest.sha256sum] = "5d29c3022897a8290f280ebe1c6853248dfa35a668e1fc02ba9c8cde4e7bf110"
17
18# remove at next version upgrade or when output changes
19# was added after intermittent repro failures poisoned the cache
20PR = "r1"
21HASHEQUIV_HASH_VERSION .= ".2"
22
23inherit pkgconfig binconfig ptest
24
25PACKAGECONFIG ??= "readline"
26PACKAGECONFIG[readline] = ",,readline"
27
28TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
29EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}' 'AR=ar rcD' 'RANLIB=ranlib -D'"
30
31do_configure:prepend() {
32 sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
33 sed -i -e s:lib/lua/:${baselib}/lua/:g src/luaconf.h
34}
35
36do_compile () {
37 oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux-readline', 'linux', d)}
38}
39
40do_install () {
41 oe_runmake \
42 'INSTALL_TOP=${D}${prefix}' \
43 'INSTALL_BIN=${D}${bindir}' \
44 'INSTALL_INC=${D}${includedir}/' \
45 'INSTALL_MAN=${D}${mandir}/man1' \
46 'INSTALL_SHARE=${D}${datadir}/lua' \
47 'INSTALL_LIB=${D}${libdir}' \
48 'INSTALL_CMOD=${D}${libdir}/lua/5.4' \
49 install
50 install -d ${D}${libdir}/pkgconfig
51
52 sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc
53 install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/
54 rmdir ${D}${datadir}/lua/5.4
55 rmdir ${D}${datadir}/lua
56}
57
58do_install_ptest () {
59 cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV_testsuites}-tests ${D}${PTEST_PATH}/test
60}
61
62BBCLASSEXTEND = "native nativesdk"