blob: 4a289c2c7b9e363d0b39d78c99011d73655d4003 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b076ad374a7d311ba3126a22b2d52596"
7
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14"
15SRC_URI[sha256sum] = "d0bba24083c01ae43457514d875f10d9ce4c1125d55b1e2573277b2410f2d068"
16
17UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
19
20DEPENDS += "python3-cython-native"
21
22inherit ptest setuptools3
23
24S = "${WORKDIR}/numpy-${PV}"
25
26CLEANBROKEN = "1"
27
28FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
29
30# install what is needed for numpy.test()
31RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
32 ${PYTHON_PN}-difflib \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-pickle \
35 ${PYTHON_PN}-shell \
36 ${PYTHON_PN}-doctest \
37 ${PYTHON_PN}-datetime \
38 ${PYTHON_PN}-distutils \
39 ${PYTHON_PN}-misc \
40 ${PYTHON_PN}-mmap \
41 ${PYTHON_PN}-netclient \
42 ${PYTHON_PN}-numbers \
43 ${PYTHON_PN}-pydoc \
44 ${PYTHON_PN}-pkgutil \
45 ${PYTHON_PN}-email \
46 ${PYTHON_PN}-compression \
47 ${PYTHON_PN}-ctypes \
48 ${PYTHON_PN}-threading \
49 ${PYTHON_PN}-multiprocessing \
50"
51RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
52 ${PYTHON_PN}-hypothesis \
53 ${PYTHON_PN}-sortedcontainers \
54 ${PYTHON_PN}-resource \
55 ldd \
56"
57
58BBCLASSEXTEND = "native nativesdk"