blob: 6ddb1d62966d20baa3b512ada6c916bb3984750c [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.org/project/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c4fa2b50f55649f43060fa04b0919b9b"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9inherit pypi distutils3
10
11SRC_URI += "file://0001-change-shebang-to-python3.patch"
12
13SRC_URI[sha256sum] = "fd11ba3d0fdb4c07fbc5ecbba0b1b719809420f25038f8ee3cd913d3faa3033a"
14
15do_install:append() {
16 # Install as pip3 and leave pip2 as default
17 rm ${D}/${bindir}/pip
18}
19
20RDEPENDS:${PN} = "\
21 python3-compile \
22 python3-io \
23 python3-html \
24 python3-json \
25 python3-multiprocessing \
26 python3-netserver \
27 python3-setuptools \
28 python3-unixadmin \
29 python3-xmlrpc \
30 python3-pickle \
31"
32
33BBCLASSEXTEND = "native nativesdk"