blob: 7ff7c5b4dd5a026ee1b9f5b664315242ee1ff110 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject"
3DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more."
4SECTION = "devel/python"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
7
8GNOMEBASEBUILDCLASS = "meson"
9inherit gnomebase distutils3-base upstream-version-is-even
10
11DEPENDS += "python3 glib-2.0"
12
13# Generating introspection data depends on a combination of native and target
14# introspection tools, and qemu to run the target tools.
15DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native prelink-native"
16
17# Even though introspection is disabled on -native, gobject-introspection package is still
18# needed for m4 macros.
19DEPENDS:append:class-native = " gobject-introspection-native"
20DEPENDS:append:class-nativesdk = " gobject-introspection-native"
21
22SRCNAME="pygobject"
23
24SRC_URI = " \
25 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
26 file://0001-Do-not-build-tests.patch \
27"
28SRC_URI[sha256sum] = "9b12616e32cfc792f9dc841d9c472a41a35b85ba67d3a6eb427e307a6fe4367b"
29
30S = "${WORKDIR}/${SRCNAME}-${PV}"
31
32PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
33
34RDEPENDS:${PN} += "python3-pkgutil"
35
36# python3-pycairo is checked on configuration -> DEPENDS
37# we don't link against python3-pycairo -> RDEPENDS
38PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo"
39
40BBCLASSEXTEND = "native"
41PACKAGECONFIG:class-native = ""