blob: ea131ef7931164be119b69d7efd01f84dc21c67d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python implementation of a sliding window memory map manager"
2DESCRIPTION = "A pure Python implementation of a sliding memory map to \
3help unifying memory mapped access on 32 and 64 bit systems and to help \
4managing resources more efficiently."
5HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
6SECTION = "devel/python"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
9
10inherit pypi setuptools3
11
12PYPI_PACKAGE = "smmap"
13
14SRC_URI[sha256sum] = "c840e62059cd3be204b0c9c9f74be2c09d5648eddd4580d9314c3ecde0b30936"
15
16RDEPENDS:${PN} += "${PYTHON_PN}-codecs \
17 ${PYTHON_PN}-mmap \
18"
19BBCLASSEXTEND = "native nativesdk"