blob: e3300b6495b1a13588cc3995bad549af04265371 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
4LICENSE = "PSFv2"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3dd7bed622743ef9b77169b3736f7990"
8
9SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
10 file://run-ptest \
11 file://create_manifest3.py \
12 file://get_module_deps3.py \
13 file://python3-manifest.json \
14 file://check_build_completeness.py \
15 file://reformat_sysconfig.py \
16 file://cgi_py.patch \
17 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
18 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
19 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
20 file://python-config.patch \
21 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
22 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
23 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
24 file://crosspythonpath.patch \
25 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
26 file://0001-test_locale.py-correct-the-test-output-format.patch \
27 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
28 file://0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
29 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
30 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
31 file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \
32 file://0001-test_ctypes.test_find-skip-without-tools-sdk.patch \
33 file://makerace.patch \
34 file://0001-sysconfig.py-use-platlibdir-also-for-purelib.patch \
35 file://0001-Lib-pty.py-handle-stdin-I-O-errors-same-way-as-maste.patch \
36 "
37
38SRC_URI:append:class-native = " \
39 file://0001-Lib-sysconfig.py-use-prefix-value-from-build-configu.patch \
40 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
41 file://12-distutils-prefix-is-inside-staging-area.patch \
42 file://0001-Don-t-search-system-for-headers-libraries.patch \
43 "
44SRC_URI[sha256sum] = "5a99f8e7a6a11a7b98b4e75e0d1303d3832cada5534068f69c7b6222a7b1b002"
45
46# exclude pre-releases for both python 2.x and 3.x
47UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
48UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
49
50CVE_PRODUCT = "python"
51
52# Upstream consider this expected behaviour
53CVE_CHECK_WHITELIST += "CVE-2007-4559"
54# This is not exploitable when glibc has CVE-2016-10739 fixed.
55CVE_CHECK_WHITELIST += "CVE-2019-18348"
56
57# This is windows only issue.
58CVE_CHECK_WHITELIST += "CVE-2020-15523"
59
60PYTHON_MAJMIN = "3.10"
61
62S = "${WORKDIR}/Python-${PV}"
63
64BBCLASSEXTEND = "native nativesdk"
65
66inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
67
68MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
69
70ALTERNATIVE:${PN}-dev = "python3-config"
71ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
72ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
73
74
75DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2 autoconf-archive-native"
76DEPENDS:append:class-target = " python3-native"
77DEPENDS:append:class-nativesdk = " python3-native"
78
79# force to use the mutex+cond implementation (https://bugs.python.org/issue41710)
80CFLAGS += "-DHAVE_BROKEN_POSIX_SEMAPHORES"
81
82EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
83EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}"
84
85export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
86
87EXTRANATIVEPATH += "python3-native"
88
89# LTO will be enabled via packageconfig depending upong distro features
90LTO:class-target = ""
91
92CACHED_CONFIGUREVARS = " \
93 ac_cv_file__dev_ptmx=yes \
94 ac_cv_file__dev_ptc=no \
95 ac_cv_working_tzset=yes \
96"
97
98# PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
99PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
100PACKAGECONFIG:class-native ??= "readline gdbm"
101PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
102PACKAGECONFIG[readline] = ",,readline"
103# Use profile guided optimisation by running PyBench inside qemu-user
104PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
105PACKAGECONFIG[tk] = ",,tk"
106PACKAGECONFIG[gdbm] = ",,gdbm"
107PACKAGECONFIG[lto] = "--with-lto,,"
108
109do_configure:prepend () {
110 mkdir -p ${B}/Modules
111 cat > ${B}/Modules/Setup.local << EOF
112*disabled*
113${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
114${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
115EOF
116}
117
118CPPFLAGS:append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
119
120EXTRA_OEMAKE = '\
121 STAGING_LIBDIR=${STAGING_LIBDIR} \
122 STAGING_INCDIR=${STAGING_INCDIR} \
123 LIB=${baselib} \
124'
125
126do_compile:prepend:class-target() {
127 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
128 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
129 cat >pgo-wrapper <<EOF
130#!/bin/sh
131cd ${B}
132$qemu_binary "\$@"
133EOF
134 chmod +x pgo-wrapper
135 fi
136}
137
138do_install:prepend() {
139 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
140}
141
142do_install:append:class-target() {
143 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
144}
145
146do_install:append:class-native() {
147 # Make sure we use /usr/bin/env python
148 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
149 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
150 done
151 # Add a symlink to the native Python so that scripts can just invoke
152 # "nativepython" and get the right one without needing absolute paths
153 # (these often end up too long for the #! parser in the kernel as the
154 # buffer is 128 bytes long).
155 ln -s python3-native/python3 ${D}${bindir}/nativepython3
156}
157
158do_install:append() {
159 for c in ${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
160 python3 ${WORKDIR}/reformat_sysconfig.py $c
161 done
162 rm ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/_sysconfigdata*.cpython*
163
164 mkdir -p ${D}${libdir}/python-sysconfigdata
165 sysconfigfile=`find ${D} -name _sysconfig*.py`
166 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
167
168 sed -i \
169 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
170 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
171 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
172 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
173 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
174 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
175
176 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
177 # being written without strict ordering, even with PYTHONHASHSEED = 0
178 # Upstream is discussing ways to solve the issue properly, until then let's
179 # just not install the problematic files.
180 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
181 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
182 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
183}
184
185do_install:append:class-nativesdk () {
186 # Make sure we use /usr/bin/env python
187 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
188 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
189 done
190 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
191}
192
193SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
194SSTATE_HASHEQUIV_FILEMAP = " \
195 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${TMPDIR} \
196 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${COREBASE} \
197 populate_sysroot:*/lib*/python3*/config-*/Makefile:${TMPDIR} \
198 populate_sysroot:*/lib*/python3*/config-*/Makefile:${COREBASE} \
199 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${TMPDIR} \
200 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${COREBASE} \
201 "
202PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
203
204py_package_preprocess () {
205 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
206 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
207 -e 's|${DEBUG_PREFIX_MAP}||g' \
208 -e 's:${HOSTTOOLS_DIR}/::g' \
209 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
210 -e 's:${RECIPE_SYSROOT}::g' \
211 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
212 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
213 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
214 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
215
216 # Reformat _sysconfigdata after modifying it so that it remains
217 # reproducible
218 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
219 python3 ${WORKDIR}/reformat_sysconfig.py $c
220 done
221
222 # Recompile _sysconfigdata after modifying it
223 cd ${PKGD}
224 sysconfigfile=`find . -name _sysconfigdata_*.py`
225 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
226 -c "from py_compile import compile; compile('$sysconfigfile')"
227 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
228 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
229 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
230 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
231 cd -
232
233 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
234
235 #Remove the unneeded copy of target sysconfig data
236 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
237}
238
239# We want bytecode precompiled .py files (.pyc's) by default
240# but the user may set it on their own conf
241INCLUDE_PYCS ?= "1"
242
243python(){
244 import collections, json
245
246 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
247 # This python changes the datastore based on the contents of a file, so mark
248 # that dependency.
249 bb.parse.mark_dependency(d, filename)
250
251 with open(filename) as manifest_file:
252 manifest_str = manifest_file.read()
253 json_start = manifest_str.find('# EOC') + 6
254 manifest_file.seek(json_start)
255 manifest_str = manifest_file.read()
256 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
257
258 # First set RPROVIDES for -native case
259 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
260 pn = 'python3'
261 rprovides = (d.getVar('RPROVIDES') or "").split()
262
263 # ${PN}-misc-native is not in the manifest
264 rprovides.append(pn + '-misc-native')
265
266 for key in python_manifest:
267 pypackage = pn + '-' + key + '-native'
268 if pypackage not in rprovides:
269 rprovides.append(pypackage)
270
271 d.setVar('RPROVIDES:class-native', ' '.join(rprovides))
272
273 # Then work on the target
274 include_pycs = d.getVar('INCLUDE_PYCS')
275
276 packages = d.getVar('PACKAGES').split()
277 pn = d.getVar('PN')
278
279 newpackages=[]
280 for key in python_manifest:
281 pypackage = pn + '-' + key
282
283 if pypackage not in packages:
284 # We need to prepend, otherwise python-misc gets everything
285 # so we use a new variable
286 newpackages.append(pypackage)
287
288 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
289 d.setVar('FILES:' + pypackage, '')
290 for value in python_manifest[key]['files']:
291 d.appendVar('FILES:' + pypackage, ' ' + value)
292
293 # Add cached files
294 if include_pycs == '1':
295 for value in python_manifest[key]['cached']:
296 d.appendVar('FILES:' + pypackage, ' ' + value)
297
298 for value in python_manifest[key]['rdepends']:
299 # Make it work with or without $PN
300 if '${PN}' in value:
301 value=value.split('-', 1)[1]
302 d.appendVar('RDEPENDS:' + pypackage, ' ' + pn + '-' + value)
303
304 for value in python_manifest[key].get('rrecommends', ()):
305 if '${PN}' in value:
306 value=value.split('-', 1)[1]
307 d.appendVar('RRECOMMENDS:' + pypackage, ' ' + pn + '-' + value)
308
309 d.setVar('SUMMARY:' + pypackage, python_manifest[key]['summary'])
310
311 # Prepending so to avoid python-misc getting everything
312 packages = newpackages + packages
313 d.setVar('PACKAGES', ' '.join(packages))
314 d.setVar('ALLOW_EMPTY:${PN}-modules', '1')
315 d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1')
316
317 if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d):
318 bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine")
319}
320
321# Files needed to create a new manifest
322
323do_create_manifest() {
324 # This task should be run with every new release of Python.
325 # We must ensure that PACKAGECONFIG enables everything when creating
326 # a new manifest, this is to base our new manifest on a complete
327 # native python build, containing all dependencies, otherwise the task
328 # wont be able to find the required files.
329 # e.g. BerkeleyDB is an optional build dependency so it may or may not
330 # be present, we must ensure it is.
331
332 cd ${WORKDIR}
333 # This needs to be executed by python-native and NOT by HOST's python
334 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
335 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
336}
337
338# bitbake python -c create_manifest
339# Make sure we have native python ready when we create a new manifest
340addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
341
342# manual dependency additions
343RRECOMMENDS:${PN}-core:append:class-nativesdk = " nativesdk-python3-modules"
344RRECOMMENDS:${PN}-crypt:append:class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
345RRECOMMENDS:${PN}-crypt:append:class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
346
347# For historical reasons PN is empty and provided by python3-modules
348FILES:${PN} = ""
349RPROVIDES:${PN}-modules = "${PN}"
350
351FILES:${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
352FILES:${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
353
354# provide python-pyvenv from python3-venv
355RPROVIDES:${PN}-venv += "${MLPREFIX}python3-pyvenv"
356
357# package libpython3
358PACKAGES =+ "libpython3 libpython3-staticdev"
359FILES:libpython3 = "${libdir}/libpython*.so.*"
360FILES:libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
361INSANE_SKIP:${PN}-dev += "dev-elf"
362INSANE_SKIP:${PN}-ptest = "dev-deps"
363
364# catch all the rest (unsorted)
365PACKAGES += "${PN}-misc"
366RDEPENDS:${PN}-misc += "\
367 ${PN}-core \
368 ${PN}-email \
369 ${PN}-codecs \
370 ${PN}-pydoc \
371 ${PN}-pickle \
372 ${PN}-audio \
373 ${PN}-numbers \
374"
375RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc"
376RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc"
377FILES:${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
378
379# catch manpage
380PACKAGES += "${PN}-man"
381FILES:${PN}-man = "${datadir}/man"
382
383# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
384RDEPENDS:libpython3:append:libc-glibc = " libgcc"
385RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig"
386RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev unzip bzip2 libgcc tzdata-europe coreutils sed"
387RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-tr-tr.iso-8859-9"
388RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}"
389RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}"
390RDEPENDS:${PN}-dev = ""
391RDEPENDS:${PN}-pydoc += "${PN}-io"
392
393RDEPENDS:${PN}-tests:append:class-target = " ${MLPREFIX}bash"
394RDEPENDS:${PN}-tests:append:class-nativesdk = " ${MLPREFIX}bash"
395
396# Python's tests contain large numbers of files we don't need in the recipe sysroots
397SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
398py3_sysroot_cleanup () {
399 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
400}