blob: f7fa66851d9aae9fb352cea93489012a1e664c4b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Tool for creating HTML, PDF, EPUB, man pages"
2DESCRIPTION = "AsciiDoc is a text document format for writing short documents, \
3articles, books and UNIX man pages."
4
5HOMEPAGE = "http://asciidoc.org/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=4e5d1baf6f20559e3bec172226a47e4e \
9 file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 "
10
11SRC_URI = "git://github.com/asciidoc/asciidoc-py3;protocol=https;branch=main"
12SRCREV = "4667219e473a24e8e645eb9b9fb0a7ddba322f44"
13
14DEPENDS = "libxml2-native libxslt-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
15
16S = "${WORKDIR}/git"
17
18# Tell xmllint where to find the DocBook XML catalogue, because right now it
19# opens /etc/xml/catalog on the host. Depends on auto-catalogs.patch
20export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
21
22inherit setuptools3
23CLEANBROKEN = "1"
24
25BBCLASSEXTEND = "native nativesdk"
26
27UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))$"