blob: 09210b68aaf9b20c97e99a6b663b6fa12bcf754d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "WebKit based web browser for GNOME"
2DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \
3It provides a simple and easy-to-use internet browsing experience."
4HOMEPAGE = "https://wiki.gnome.org/Apps/Web"
5BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany"
6LICENSE = "GPLv3+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9DEPENDS = " \
10 webkitgtk \
11 gcr \
12 gsettings-desktop-schemas \
13 nettle \
14 json-glib \
15 libarchive \
16 libdazzle \
17 libhandy \
18 libportal \
19 glib-2.0-native \
20 "
21
22GNOMEBASEBUILDCLASS = "meson"
23inherit gnomebase gsettings features_check gettext mime-xdg
24REQUIRED_DISTRO_FEATURES = "x11 opengl"
25
26SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
27 file://0002-help-meson.build-disable-the-use-of-yelp.patch \
28 file://migrator.patch \
29 file://distributor.patch \
30 "
31SRC_URI[archive.sha256sum] = "b39d1825492595b0b74c5d6a6686a857f9419dfa4c02f8013c297bc870e26dd0"
32
33EXTRA_OEMESON += "-Dsoup2=disabled"
34
35# Developer mode enables debugging
36PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false"
37
38FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
39RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"