blob: d96caf08d8ea4ed5d3123927978ae23597f145f4 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Middleware layer between GObject-using C libraries and language bindings"
2DESCRIPTION = "GObject Introspection is a project for providing machine \
3readable introspection data of the API of C libraries. This introspection \
4data can be used in several different use cases, for example automatic code \
5generation for bindings, API verification and documentation generation."
6HOMEPAGE = "https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/gobject-introspection/issues"
8SECTION = "libs"
9LICENSE = "LGPLv2+ & GPLv2+ & MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=c434e8128a68bedd59b80b2ac1eb1c4a \
11 file://tools/compiler.c;endline=20;md5=fc5007fc20022720e6c0b0cdde41fabd \
12 file://giscanner/sourcescanner.c;endline=22;md5=194d6e0c1d00662f32d030ce44de8d39 \
13 file://girepository/giregisteredtypeinfo.c;endline=21;md5=661847611ae6979465415f31a759ba27 \
14 "
15
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${@oe.utils.trim_version("${PV}", 2)}/${BPN}-${PV}.tar.xz \
17 file://0001-giscanner-ignore-error-return-codes-from-ldd-wrapper.patch \
18 "
19
20SRC_URI[sha256sum] = "902b4906e3102d17aa2fcb6dad1c19971c70f2a82a159ddc4a94df73a3cafc4a"
21
22SRC_URI:append:class-native = " file://0001-Relocate-the-repository-directory-for-native-builds.patch"
23
24inherit meson pkgconfig gtk-doc python3native qemu gobject-introspection-data upstream-version-is-even multilib_script
25
26GTKDOC_MESON_OPTION = "gtk_doc"
27
28MULTILIB_SCRIPTS = "${PN}:${bindir}/g-ir-annotation-tool ${PN}:${bindir}/g-ir-scanner"
29
30DEPENDS += " libffi zlib glib-2.0 python3 flex-native bison-native autoconf-archive"
31
32# target build needs qemu to run temporary introspection binaries created
33# on the fly by g-ir-scanner and a native version of itself to run
34# native versions of its own tools during build.
35# Also prelink-rtld is used to find out library dependencies of introspection binaries
36# (standard ldd doesn't work when cross-compiling).
37DEPENDS:append:class-target = " gobject-introspection-native qemu-native prelink-native"
38
39# needed for writing out the qemu wrapper script
40export STAGING_DIR_HOST
41export B
42
43PACKAGECONFIG ?= ""
44PACKAGECONFIG[doctool] = "-Ddoctool=enabled,-Ddoctool=disabled,python3-mako,"
45
46# Configure target build to use native tools of itself and to use a qemu wrapper
47# and optionally to generate introspection data
48EXTRA_OEMESON:class-target = " \
49 -Dgi_cross_use_prebuilt_gi=true \
50 -Dgi_cross_binary_wrapper=${B}/g-ir-scanner-qemuwrapper \
51 -Dgi_cross_ldd_wrapper=${B}/g-ir-scanner-lddwrapper \
52 -Dgi_cross_pkgconfig_sysroot_path=${PKG_CONFIG_SYSROOT_DIR} \
53 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dbuild_introspection_data=true', '-Dbuild_introspection_data=false', d)} \
54 ${@'-Dgir_dir_prefix=${libdir}' if d.getVar('MULTILIBS') else ''} \
55"
56
57# Need to ensure ld.so.conf exists so prelink-native works
58# both before we build and if we install from sstate
59do_configure[prefuncs] += "gobject_introspection_preconfigure"
60python gobject_introspection_preconfigure () {
61 oe.utils.write_ld_so_conf(d)
62}
63
64do_configure:prepend:class-native() {
65 # Tweak the native python scripts so that they don't refer to the
66 # full path of native python binary (the solution is taken from glib-2.0 recipe)
67 # This removes the risk of exceeding Linux kernel's shebang line limit (128 bytes)
68 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in
69}
70
71do_configure:prepend:class-target() {
72 # Write out a qemu wrapper that will be given to gi-scanner so that it
73 # can run target helper binaries through that.
74 qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
75 cat > ${B}/g-ir-scanner-qemuwrapper << EOF
76#!/bin/sh
77# Use a modules directory which doesn't exist so we don't load random things
78# which may then get deleted (or their dependencies) and potentially segfault
79export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy
80
81$qemu_binary "\$@"
82if [ \$? -ne 0 ]; then
83 echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help."
84 echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )"
85 exit 1
86fi
87EOF
88 chmod +x ${B}/g-ir-scanner-qemuwrapper
89
90 # Write out a wrapper for g-ir-scanner itself, which will be used when building introspection files
91 # for glib-based packages. This wrapper calls the native version of the scanner, and tells it to use
92 # a qemu wrapper for running transient target binaries produced by the scanner, and an include directory
93 # from the target sysroot.
94 cat > ${B}/g-ir-scanner-wrapper << EOF
95#!/bin/sh
96# This prevents g-ir-scanner from writing cache data to user's HOME dir
97export GI_SCANNER_DISABLE_CACHE=1
98
99g-ir-scanner --lib-dirs-envvar=GIR_EXTRA_LIBS_PATH --use-binary-wrapper=${STAGING_BINDIR}/g-ir-scanner-qemuwrapper --use-ldd-wrapper=${STAGING_BINDIR}/g-ir-scanner-lddwrapper --add-include-path=${STAGING_DATADIR}/gir-1.0 --add-include-path=${STAGING_LIBDIR}/gir-1.0 "\$@"
100EOF
101 chmod +x ${B}/g-ir-scanner-wrapper
102
103 # Write out a wrapper for g-ir-compiler, which runs the target version of it through qemu.
104 # g-ir-compiler writes out the raw content of a C struct to disk, and therefore is architecture dependent.
105 cat > ${B}/g-ir-compiler-wrapper << EOF
106#!/bin/sh
107${STAGING_BINDIR}/g-ir-scanner-qemuwrapper ${STAGING_BINDIR}/g-ir-compiler "\$@"
108EOF
109 chmod +x ${B}/g-ir-compiler-wrapper
110
111 # Write out a wrapper to use instead of ldd, which does not work when a binary is built
112 # for a different architecture
113 cat > ${B}/g-ir-scanner-lddwrapper << EOF
114#!/bin/sh
115prelink-rtld --root=$STAGING_DIR_HOST "\$@"
116EOF
117 chmod +x ${B}/g-ir-scanner-lddwrapper
118
119 # Also tweak the target python scripts so that they don't refer to the
120 # native version of python binary (the solution is taken from glib-2.0 recipe)
121 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in
122}
123
124do_compile:prepend() {
125 # This prevents g-ir-scanner from writing cache data to $HOME
126 export GI_SCANNER_DISABLE_CACHE=1
127
128 # Needed to run g-ir unit tests, which won't be able to find the built libraries otherwise
129 export GIR_EXTRA_LIBS_PATH=$B/.libs
130}
131
132do_install:prepend() {
133 # This prevents g-ir-scanner from writing cache data to $HOME
134 export GI_SCANNER_DISABLE_CACHE=1
135}
136
137# Our wrappers need to be available system-wide, because they will be used
138# to build introspection files for all other gobject-based packages
139do_install:append:class-target() {
140 install -d ${D}${bindir}/
141 install ${B}/g-ir-scanner-qemuwrapper ${D}${bindir}/
142 install ${B}/g-ir-scanner-wrapper ${D}${bindir}/
143 install ${B}/g-ir-compiler-wrapper ${D}${bindir}/
144 install ${B}/g-ir-scanner-lddwrapper ${D}${bindir}/
145}
146
147# we need target versions of introspection tools in sysroot so that they can be run via qemu
148# when building introspection files in other packages
149SYSROOT_DIRS:append:class-target = " ${bindir}"
150
151SYSROOT_PREPROCESS_FUNCS:append:class-target = " gi_binaries_sysroot_preprocess"
152gi_binaries_sysroot_preprocess() {
153 # Tweak the binary names in the introspection pkgconfig file, so that it
154 # picks up our wrappers which do the cross-compile and qemu magic.
155 sed -i \
156 -e "s|g_ir_scanner=.*|g_ir_scanner=${bindir}/g-ir-scanner-wrapper|" \
157 -e "s|g_ir_compiler=.*|g_ir_compiler=${bindir}/g-ir-compiler-wrapper|" \
158 ${SYSROOT_DESTDIR}${libdir}/pkgconfig/gobject-introspection-1.0.pc
159}
160
161SYSROOT_PREPROCESS_FUNCS:append = " gi_ldsoconf_sysroot_preprocess"
162gi_ldsoconf_sysroot_preprocess () {
163 mkdir -p ${SYSROOT_DESTDIR}${bindir}
164 dest=${SYSROOT_DESTDIR}${bindir}/postinst-ldsoconf-${PN}
165 echo "#!/bin/sh" > $dest
166 echo "mkdir -p ${STAGING_DIR_TARGET}${sysconfdir}" >> $dest
167 echo "echo ${base_libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
168 echo "echo ${libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
169 chmod 755 $dest
170}
171
172# Remove wrapper files from the package, only used for cross-compiling
173PACKAGE_PREPROCESS_FUNCS += "gi_package_preprocess"
174gi_package_preprocess() {
175 rm -f ${PKGD}${bindir}/g-ir-scanner-qemuwrapper
176 rm -f ${PKGD}${bindir}/g-ir-scanner-wrapper
177 rm -f ${PKGD}${bindir}/g-ir-compiler-wrapper
178 rm -f ${PKGD}${bindir}/g-ir-scanner-lddwrapper
179}
180
181SSTATE_SCAN_FILES += "g-ir-scanner-qemuwrapper g-ir-scanner-wrapper g-ir-compiler-wrapper g-ir-scanner-lddwrapper Gio-2.0.gir postinst-ldsoconf-${PN}"
182
183# .typelib files are needed at runtime and so they go to the main package
184FILES:${PN}:append = " ${libdir}/girepository-*/*.typelib"
185
186# .gir files go to dev package, as they're needed for developing (but not for running)
187# things that depends on introspection.
188FILES:${PN}-dev:append = " ${datadir}/gir-*/*.gir ${libdir}/gir-*/*.gir"
189FILES:${PN}-dev:append = " ${datadir}/gir-*/*.rnc"
190
191# These are used by gobject-based packages
192# to generate transient introspection binaries
193FILES:${PN}-dev:append = " ${datadir}/gobject-introspection-1.0/gdump.c \
194 ${datadir}/gobject-introspection-1.0/Makefile.introspection"
195
196# These are used by dependent packages (e.g. pygobject) to build their
197# testsuites.
198FILES:${PN}-dev:append = " ${datadir}/gobject-introspection-1.0/tests/*.c \
199 ${datadir}/gobject-introspection-1.0/tests/*.h"
200
201FILES:${PN}-dbg += "${libdir}/gobject-introspection/giscanner/.debug/"
202FILES:${PN}-staticdev += "${libdir}/gobject-introspection/giscanner/*.a"
203
204RDEPENDS:${PN} = "python3-pickle python3-xml"
205
206BBCLASSEXTEND = "native"