blob: c39be55d5fabbae15ef9d1a5ecfeb94e2782a955 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229"
10
11SRCREV = "2fb89a0072ae7316af1c856f22663fde4928128a"
12SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https \
13 file://0001-generate-glslang-pkg-config.patch"
14UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
15S = "${WORKDIR}/git"
16
17inherit cmake python3native
18
19EXTRA_OECMAKE = " \
20 -DCMAKE_BUILD_TYPE=Release \
21 -DBUILD_SHARED_LIBS=ON \
22 -DENABLE_PCH=OFF \
23 -DENABLE_CTEST=OFF \
24 -DBUILD_EXTERNAL=OFF \
25"
26
27SOLIBSDEV = "glslang.so"
28# all the other libraries are unversioned, so pack it on PN
29FILES:${PN} += "${libdir}/*.so"
30
31BBCLASSEXTEND = "native nativesdk"