blob: ac4ee3eb2322f6d3c531aaa73af4e046890c67ef [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "General-purpose library specifically developed for the WPE-flavored port of WebKit."
2HOMEPAGE = "https://github.com/WebPlatformForEmbedded/libwpe"
3BUGTRACKER = "https://github.com/WebPlatformForEmbedded/libwpe/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"
7DEPENDS = "virtual/egl libxkbcommon"
8
9inherit cmake features_check pkgconfig
10
11REQUIRED_DISTRO_FEATURES = "opengl"
12
13SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[sha256sum] = "e8eeca228a6b4c36294cfb63f7d3ba9ada47a430904a5a973b3c99c96a44c18c"
15
16# This is a tweak of upstream-version-is-even needed because
17# ipstream directory contains tarballs for other components as well.
18UPSTREAM_CHECK_REGEX = "libwpe-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"