blob: ba6c54412a6fa7a7da0a086abb0c0f54d7584346 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "WPE's backend based on a freedesktop.org stack."
2HOMEPAGE = "https://github.com/Igalia/WPEBackend-fdo"
3BUGTRACKER = "https://github.com/Igalia/WPEBackend-fdo/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1f62cef2e3645e3e74eb05fd389d7a66"
7DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe libepoxy"
8
9DEPENDS:append:class-target = " wayland-native"
10
11inherit meson features_check pkgconfig
12
13REQUIRED_DISTRO_FEATURES = "opengl"
14
15SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
16SRC_URI[sha256sum] = "6239c9c15523410798d66315de6b491712ab30009ba180f3e0dd076d9b0074ac"
17
18# This is a tweak of upstream-version-is-even needed because
19# ipstream directory contains tarballs for other components as well.
20UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"