blob: 2416835d370616a11c55dc6abb985d93749ce245 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "ITS Tool allows you to translate your XML documents with PO files"
2DESCRIPTION = "It extracts messages from XML files and outputs PO template \
3files, then merges translations from MO files to create translated \
4XML files. It determines what to translate and how to chunk it into \
5messages using the W3C Internationalization Tag Set (ITS). "
6HOMEPAGE = "http://itstool.org/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5"
9
10inherit autotools python3native
11
12DEPENDS = "libxml2-native"
13
14SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2 \
15 "
16SRC_URI:append:class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
17SRC_URI:append:class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
18SRC_URI:append:class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch"
19
20SRC_URI[sha256sum] = "6b9a7cd29a12bb95598f5750e8763cee78836a1a207f85b74d8b3275b27e87ca"
21
22BBCLASSEXTEND = "native nativesdk"
23
24RDEPENDS:${PN} += "libxml2-python"