blob: d7aecc706c4be7dcca952093e6bdcbbe330a415b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A library for atomic integer operations"
2DESCRIPTION = "Package provides semi-portable access to hardware-provided atomic memory update operations on a number of architectures."
3HOMEPAGE = "https://github.com/ivmai/libatomic_ops/"
4SECTION = "optional"
5PROVIDES += "libatomics-ops"
6LICENSE = "GPLv2 & MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://doc/LICENSING.txt;md5=e00dd5c8ac03a14c5ae5225a4525fa2d \
9 "
10
11SRC_URI = "https://github.com/ivmai/libatomic_ops/releases/download/v${PV}/libatomic_ops-${PV}.tar.gz"
12UPSTREAM_CHECK_URI = "https://github.com/ivmai/libatomic_ops/releases"
13
14SRC_URI[sha256sum] = "f0ab566e25fce08b560e1feab6a3db01db4a38e5bc687804334ef3920c549f3e"
15
16S = "${WORKDIR}/libatomic_ops-${PV}"
17
18ALLOW_EMPTY:${PN} = "1"
19
20inherit autotools pkgconfig
21
22BBCLASSEXTEND = "native nativesdk"