blob: b33522dfc424bd399aa362768d36a02212e198c7 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2DESCRIPTION = "libexif is a library for parsing, editing, and saving EXIF data. It is \
3intended to replace lots of redundant implementations in command-line \
4utilities and programs with GUIs."
5HOMEPAGE = "https://libexif.github.io/"
6SECTION = "libs"
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
9
10def version_underscore(v):
11 return "_".join(v.split("."))
12
13SRC_URI = "https://github.com/libexif/libexif/releases/download/v${PV}/libexif-${PV}.tar.xz \
14 "
15
16SRC_URI[sha256sum] = "a740a99920eb81ae0aa802bb46e683ce6e0cde061c210f5d5bde5b8572380431"
17
18UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/"
19
20inherit autotools gettext
21
22EXTRA_OECONF += "--disable-docs"
23
24BBCLASSEXTEND = "native nativesdk"