blob: 3ec6f135c5d6ffcd832cccf36ee9e2792de74e4d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3HOMEPAGE = "https://github.com/seccomp/libseccomp"
4SECTION = "security"
5LICENSE = "LGPL-2.1"
6LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
7
8DEPENDS += "gperf-native"
9
10PV .= "+git${SRCPV}"
11SRCREV = "2457dec1a90101d720e89e8027376742e2f3c327"
12
13SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=main \
14 file://0001-configure.ac-Bump-version-to-2.5.99.patch \
15 file://0001-arch-Add-riscv32-architecture-support.patch \
16 file://0002-man-Add-RISCV64-to-arch-list.patch \
17 file://0003-syscalls-update-the-syscall-defs-for-Linux-v5.15.0-r.patch \
18 file://0004-syscalls-Add-quotactl_path.patch \
19 file://run-ptest \
20 "
21
22S = "${WORKDIR}/git"
23
24inherit autotools-brokensep pkgconfig ptest features_check
25
26REQUIRED_DISTRO_FEATURES = "seccomp"
27
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
30
31DISABLE_STATIC = ""
32
33do_compile_ptest() {
34 oe_runmake -C tests check-build
35}
36
37do_install_ptest() {
38 install -d ${D}${PTEST_PATH}/tests
39 install -d ${D}${PTEST_PATH}/tools
40 for file in $(find tests/* -executable -type f); do
41 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
42 done
43 for file in $(find tests/*.tests -type f); do
44 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
45 done
46 for file in $(find tools/* -executable -type f); do
47 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
48 done
49 # Overwrite libtool wrappers with real executables
50 for file in $(find tools/.libs/* -executable -type f); do
51 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
52 done
53}
54
55FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
56FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
57
58RDEPENDS:${PN}-ptest = "coreutils bash"