blob: ea34373a67472d840e5510516d206929a688794d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "An HTTP library implementation in C"
2DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
4HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
7LICENSE = "LGPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
10DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl"
11
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
15SRC_URI[sha256sum] = "33b1d4e0d639456c675c227877e94a8078d731233e2d57689c11abcef7d3c48e"
16
17CVE_PRODUCT = "libsoup"
18
19S = "${WORKDIR}/libsoup-${PV}"
20
21inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
22
23UPSTREAM_CHECK_REGEX = "libsoup-(?P<pver>2(\.(?!99)\d+)+)\.tar"
24
25GIR_MESON_ENABLE_FLAG = 'enabled'
26GIR_MESON_DISABLE_FLAG = 'disabled'
27
28# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
29PACKAGECONFIG ??= ""
30PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
31PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
32
33EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
34
35GTKDOC_MESON_OPTION = "gtk_doc"
36
37# When built without gnome support, libsoup-2.4 will contain only one shared lib
38# and will therefore become subject to renaming by debian.bbclass. Prevent
39# renaming in order to keep the package name consistent regardless of whether
40# gnome support is enabled or disabled.
41DEBIAN_NOAUTONAME:${PN} = "1"
42
43# glib-networking is needed for SSL, proxies, etc.
44RRECOMMENDS:${PN} = "glib-networking"
45
46BBCLASSEXTEND = "native nativesdk"