blob: 3de509a27c1c08ccfaa3dec5d6cf475e4ae70dea [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases"
8
9SRC_URI = "\
10 https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \
11 file://0001-fetch-ocsp-response-use-python3.patch \
12"
13SRC_URI[sha256sum] = "abdc4addccadbc7d89abe27c4d6427d78e57d139f69c1f45749227393c68bf79"
14
15inherit cmake manpages python3native
16PACKAGECONFIG[manpages] = ""
17
18# examples are never installed, and don't need to be built in the
19# first place
20EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF"
21
22PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
23
24RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
25RDEPENDS:${PN}:class-native = ""
26RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
27
28ALLOW_EMPTY:${PN} = "1"
29FILES:${PN} = ""
30FILES:lib${PN} = "${libdir}/*${SOLIBS}"
31FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
32FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
33FILES:${PN}-server = "${bindir}/nghttpd"
34
35BBCLASSEXTEND = "native nativesdk"