Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenGL function pointer management library" |
| 2 | DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \ |
| 3 | glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \ |
| 4 | very little knowledge needed on their part. They get to read GL specs and \ |
| 5 | write code using undecorated function names like glCompileShader()." |
| 6 | HOMEPAGE = "https://github.com/anholt/libepoxy/" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b" |
| 11 | |
| 12 | SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \ |
| 13 | file://0001-dispatch_common.h-define-also-EGL_NO_X11.patch \ |
| 14 | " |
| 15 | SRC_URI[md5sum] = "00f47ad447321f9dc59f85bc1c9d0467" |
| 16 | SRC_URI[sha256sum] = "0bd2cc681dfeffdef739cb29913f8c3caa47a88a451fd2bc6e606c02997289d2" |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases" |
| 18 | |
| 19 | inherit meson pkgconfig features_check |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = "opengl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl" |
| 24 | PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl" |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl" |
| 26 | |
| 27 | EXTRA_OEMESON += "-Dtests=false" |
| 28 | |
| 29 | PACKAGECONFIG_class-native = "egl x11" |
| 30 | PACKAGECONFIG_class-nativesdk = "egl x11" |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |
| 33 | |