blob: 691670c31e68b21965cd5963b1def563b78901c7 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
10# Checksums available at https://go.dev/dl/
11SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
Andrew Geissler20137392023-10-12 04:59:14 -060012SRC_URI[go_linux_amd64.sha256sum] = "80d34f1fd74e382d86c2d6102e0e60d4318461a7c2f457ec1efc4042752d4248"
13SRC_URI[go_linux_arm64.sha256sum] = "fb3c7e15fc4413c5b81eb9f26dbd7cd4faedd5c720b30fa8e2ff77457f74cab6"
14SRC_URI[go_linux_ppc64le.sha256sum] = "ebac6e713810174f9ffd7f48c17c373fbf359d50d8e6233b1dfbbdebd524fd1c"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16UPSTREAM_CHECK_URI = "https://golang.org/dl/"
17UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
18
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050019CVE_PRODUCT = "go"
20
Andrew Geissler517393d2023-01-13 08:55:19 -060021S = "${WORKDIR}/go"
22
23inherit goarch native
24
25do_compile() {
26 :
27}
28
29make_wrapper() {
30 rm -f ${D}${bindir}/$1
31 cat <<END >${D}${bindir}/$1
32#!/bin/bash
33here=\`dirname \$0\`
34export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
35\$here/../lib/go/bin/$1 "\$@"
36END
37 chmod +x ${D}${bindir}/$1
38}
39
40do_install() {
41 find ${S} -depth -type d -name testdata -exec rm -rf {} +
42
43 install -d ${D}${bindir} ${D}${libdir}/go
44 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
45
46 for f in ${S}/bin/*
47 do
48 make_wrapper `basename $f`
49 done
50}