blob: a177586cacce726c18aaf83c70ad6e1e2f2942cf [file] [log] [blame]
George Hungf089ba12020-05-20 17:22:25 +08001PR = "r1"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
5
6inherit systemd
7inherit obmc-phosphor-systemd
8
9
10SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
11 file://bmc-verify.sh \
12 file://config-bmc.json \
13 "
14
15FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
16
17DEPENDS += "systemd"
18DEPENDS += "phosphor-ipmi-flash"
19RDEPENDS_${PN} = "bash"
20
21do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 ${WORKDIR}/bmc-verify.sh ${D}${bindir}/
24
25 install -d ${D}${systemd_system_unitdir}
26 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmc-verify.service ${D}${systemd_system_unitdir}
27
28 install -d ${D}${datadir}/phosphor-ipmi-flash
29 install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
30}
31
32
33SYSTEMD_PACKAGES = "${PN}"
34SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bmc-verify.service"