blob: c9b2e9d5e42e44725f85ad5dbe488f982ffb504f [file] [log] [blame]
Vincent Chouf16ca762022-09-12 10:31:29 -05001SUMMARY = "OpenBMC Mori Boot Status LED Service"
2DESCRIPTION = "OpenBMC Mori Boot Status LED Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS:${PN} += "bash"
11
12SRC_URI = " file://boot-status-led.sh \
13 file://boot-status-led.service \
14 "
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/boot-status-led.sh ${D}${bindir}/
19
20 install -d ${D}${systemd_system_unitdir}
21 install -m 0644 ${WORKDIR}/boot-status-led.service ${D}${systemd_system_unitdir}
22}
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE:${PN} = "boot-status-led.service"