blob: dbc195d35495855edb03e3081bbf78293edfe2aa [file] [log] [blame]
Andrew Geisslerf1e44062021-04-15 15:52:46 -05001SUMMARY = "Linux Kernel Runtime Guard"
2DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
3kernel and detection of security vulnerability exploits against the kernel."
4SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/"
6LICENSE = "GPLv2"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=d931f44a1f4be309bcdac742d7ed92f9"
9
10DEPENDS = "virtual/kernel elfutils"
11
12SRC_URI = "https://www.openwall.com/lkrg/lkrg-${PV}.tar.gz \
13 file://makefile_cleanup.patch "
14
15SRC_URI[sha256sum] = "a997e4d98962c359f3af163bbcfa38a736d2a50bfe35c15065b74cb57f8742bf"
16
17S = "${WORKDIR}/lkrg-${PV}"
18
19inherit module kernel-module-split
20
21MAKE_TARGETS = "modules"
22
23MODULE_NAME = "p_lkrg"
24
25module_do_install() {
26 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
27 install -m 0644 ${MODULE_NAME}.ko \
28 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
29}
30
31RPROVIDES_${PN} += "kernel-module-lkrg"
32
33COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"