blob: 5b6dc995cee0006b1d3a921619943d5f2ff6ba37 [file] [log] [blame]
Andrew Geisslerd1d22e62020-10-16 10:14:32 -05001SUMMARY = "EST is used for secure certificate \
2enrollment and is compatible with Suite B certs (as well as RSA \
3and DSA certificates)"
4
5LICENSE = "OpenSSL"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ecb78acde8e3b795de8ef6b61aed5885"
7
8SRCREV = "4ca02c6d7540f2b1bcea278a4fbe373daac7103b"
Andrew Geisslerf1e44062021-04-15 15:52:46 -05009SRC_URI = "git://github.com/cisco/libest;branch=main"
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050010
11DEPENDS = "openssl"
12
13#fatal error: execinfo.h: No such file or directory
14DEPENDS_append_libc-musl = " libexecinfo"
15
16inherit autotools-brokensep
17
18EXTRA_OECONF = "--disable-pthreads --with-ssl-dir=${STAGING_LIBDIR}"
19
20CFLAGS += "-fcommon"
21LDFLAGS_append_libc-musl = " -lexecinfo"
22
23S = "${WORKDIR}/git"
24
25PACKAGES = "${PN} ${PN}-dbg ${PN}-dev"
26
27FILES_${PN} = "${bindir}/* ${libdir}/libest-3.2.0p.so"