blob: 8e340d9f5c2996941943dd459c4f8708e7d0f455 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Common code for generating core reference images
2#
3# Copyright (C) 2007-2011 Linux Foundation
4
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8# IMAGE_FEATURES control content of the core reference images
9#
10# By default we install packagegroup-core-boot and packagegroup-base-extended packages;
11# this gives us working (console only) rootfs.
12#
13# Available IMAGE_FEATURES:
14#
15# - x11 - X server
16# - x11-base - X server with minimal environment
17# - x11-sato - OpenedHand Sato environment
18# - tools-debug - debugging tools
19# - eclipse-debug - Eclipse remote debugging support
20# - tools-profile - profiling tools
21# - tools-testapps - tools usable to make some device tests
22# - tools-sdk - SDK (C/C++ compiler, autotools, etc.)
23# - nfs-server - NFS server
24# - nfs-client - NFS client
25# - ssh-server-dropbear - SSH server (dropbear)
26# - ssh-server-openssh - SSH server (openssh)
27# - qt4-pkgs - Qt4/X11 and demo applications
28# - hwcodecs - Install hardware acceleration codecs
29# - package-management - installs package management tools and preserves the package manager database
30# - debug-tweaks - makes an image suitable for development, e.g. allowing passwordless root logins
31# - dev-pkgs - development packages (headers, etc.) for all installed packages in the rootfs
32# - dbg-pkgs - debug symbol packages for all installed packages in the rootfs
33# - doc-pkgs - documentation packages for all installed packages in the rootfs
34# - ptest-pkgs - ptest packages for all ptest-enabled recipes
35# - read-only-rootfs - tweaks an image to support read-only rootfs
36#
37FEATURE_PACKAGES_x11 = "packagegroup-core-x11"
38FEATURE_PACKAGES_x11-base = "packagegroup-core-x11-base"
39FEATURE_PACKAGES_x11-sato = "packagegroup-core-x11-sato"
40FEATURE_PACKAGES_tools-debug = "packagegroup-core-tools-debug"
41FEATURE_PACKAGES_eclipse-debug = "packagegroup-core-eclipse-debug"
42FEATURE_PACKAGES_tools-profile = "packagegroup-core-tools-profile"
43FEATURE_PACKAGES_tools-testapps = "packagegroup-core-tools-testapps"
44FEATURE_PACKAGES_tools-sdk = "packagegroup-core-sdk packagegroup-core-standalone-sdk-target"
45FEATURE_PACKAGES_nfs-server = "packagegroup-core-nfs-server"
46FEATURE_PACKAGES_nfs-client = "packagegroup-core-nfs-client"
47FEATURE_PACKAGES_ssh-server-dropbear = "packagegroup-core-ssh-dropbear"
48FEATURE_PACKAGES_ssh-server-openssh = "packagegroup-core-ssh-openssh"
49FEATURE_PACKAGES_qt4-pkgs = "packagegroup-core-qt-demoapps"
50FEATURE_PACKAGES_hwcodecs = "${MACHINE_HWCODECS}"
51
52
53# IMAGE_FEATURES_REPLACES_foo = 'bar1 bar2'
54# Including image feature foo would replace the image features bar1 and bar2
55IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear"
56
57# IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2'
58# An error exception would be raised if both image features foo and bar1(or bar2) are included
59
60MACHINE_HWCODECS ??= ""
61
62CORE_IMAGE_BASE_INSTALL = '\
63 packagegroup-core-boot \
64 packagegroup-base-extended \
65 \
66 ${CORE_IMAGE_EXTRA_INSTALL} \
67 '
68
69CORE_IMAGE_EXTRA_INSTALL ?= ""
70
71IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
72
73inherit image