blob: fac074d6101de32cea8036524be5fa8e3b184aaa [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# This is for perl modules that use the new Build.PL build system
3#
4inherit cpan-base perlnative
5
6EXTRA_CPAN_BUILD_FLAGS ?= ""
7
8# Env var which tells perl if it should use host (no) or target (yes) settings
9export PERLCONFIGTARGET = "${@is_target(d)}"
10export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
Patrick Williamsf1e5d692016-03-30 15:21:19 -050011export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${@get_perl_version(d)}/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012export LD = "${CCLD}"
13
14cpan_build_do_configure () {
15 if [ "${@is_target(d)}" = "yes" ]; then
16 # build for target
17 . ${STAGING_LIBDIR}/perl/config.sh
18 fi
19
Patrick Williamsf1e5d692016-03-30 15:21:19 -050020 perl Build.PL --installdirs vendor --destdir ${D} \
21 ${EXTRA_CPAN_BUILD_FLAGS}
22
23 # Build.PLs can exit with success without generating a
24 # Build, e.g. in cases of missing configure time
25 # dependencies. This is considered a best practice by
26 # cpantesters.org. See:
27 # * http://wiki.cpantesters.org/wiki/CPANAuthorNotes
28 # * http://www.nntp.perl.org/group/perl.qa/2008/08/msg11236.html
29 [ -e Build ] || bbfatal "No Build was generated by Build.PL"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030}
31
32cpan_build_do_compile () {
Patrick Williamsf1e5d692016-03-30 15:21:19 -050033 perl Build verbose=1
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034}
35
36cpan_build_do_install () {
Patrick Williamsf1e5d692016-03-30 15:21:19 -050037 perl Build install --destdir ${D}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038}
39
40EXPORT_FUNCTIONS do_configure do_compile do_install