blob: 8defa5b743d7416db731f9dde85e200cb7eab5cf [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://configure-targets.patch \
15 file://shared-libs.patch \
16 file://oe-ldflags.patch \
17 file://engines-install-in-libdir-ssl.patch \
18 file://debian1.0.2/block_diginotar.patch \
19 file://debian1.0.2/block_digicert_malaysia.patch \
20 file://debian/ca.patch \
21 file://debian/c_rehash-compat.patch \
22 file://debian/debian-targets.patch \
23 file://debian/man-dir.patch \
24 file://debian/man-section.patch \
25 file://debian/no-rpath.patch \
26 file://debian/no-symbolic.patch \
27 file://debian/pic.patch \
28 file://debian/version-script.patch \
29 file://openssl_fix_for_x32.patch \
30 file://fix-cipher-des-ede3-cfb1.patch \
31 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
32 file://find.pl \
33 file://openssl-fix-des.pod-error.patch \
34 file://Makefiles-ptest.patch \
35 file://ptest-deps.patch \
36 file://run-ptest \
37 file://crypto_use_bigint_in_x86-64_perl.patch \
38 file://openssl-1.0.2a-x32-asm.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050039 file://ptest_makefile_deps.patch \
40 file://CVE-2015-3193-bn-asm-x86_64-mont5.pl-fix-carry-propagating-bug-CVE.patch \
41 file://CVE-2015-3194-1-Add-PSS-parameter-check.patch \
42 file://0001-Add-test-for-CVE-2015-3194.patch \
43 file://CVE-2015-3195-Fix-leak-with-ASN.1-combine.patch \
44 file://CVE-2015-3197.patch \
45 file://CVE-2016-0701_1.patch \
46 file://CVE-2016-0701_2.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047 "
48
49SRC_URI[md5sum] = "38dd619b2e77cbac69b99f52a053d25a"
50SRC_URI[sha256sum] = "671c36487785628a703374c652ad2cebea45fa920ae5681515df25d9f2c9a8c8"
51
52PACKAGES =+ " \
53 ${PN}-engines \
54 ${PN}-engines-dbg \
55 "
56
57FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
58FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
59
60PARALLEL_MAKE = ""
61PARALLEL_MAKEINST = ""
62
63do_configure_prepend() {
64 cp ${WORKDIR}/find.pl ${S}/util/find.pl
65}
Patrick Williamsf1e5d692016-03-30 15:21:19 -050066
67# The crypto_use_bigint patch means that perl's bignum module needs to be
68# installed, but some distributions (for example Fedora 23) don't ship it by
69# default. As the resulting error is very misleading check for bignum before
70# building.
71do_configure_prepend() {
72 if ! perl -Mbigint -e true; then
73 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
74 fi
75}