blob: ed46b5e096d076c8bcca6bc24b814c11a714f5ad [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
15 file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
16 file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
17 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
18 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
19 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
20"
21
22DEPENDS = "attr libaio libcap acl openssl zip-native"
23SRCREV = "77d0b7fd0148ce657c5a25060667e978c07662a0"
24
25SRC_URI = "git://github.com/linux-test-project/ltp.git \
26 file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
27 file://ltp-Do-not-link-against-libfl.patch \
28 file://make-setregid02-work.patch \
29 file://add-knob-for-numa.patch \
30 file://add-knob-for-tirpc.patch \
31 file://0001-ltp-vma03-fix-the-alginment-of-page-size.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050032 file://0001-replace-inline-with-static-inline-for-gcc-5.x.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033"
34
35S = "${WORKDIR}/git"
36
37inherit autotools-brokensep
38
39TARGET_CC_ARCH += "${LDFLAGS}"
40
41export prefix = "/opt/ltp"
42export exec_prefix = "/opt/ltp"
43
44PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
45EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
46EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite "
47# ltp network/rpc test cases ftbfs when libtirpc is found
48EXTRA_OECONF += " --without-tirpc "
49
50# The makefiles make excessive use of make -C and several include testcases.mk
51# which triggers a build of the syscall header. To reproduce, build ltp,
52# then delete the header, then "make -j XX" and watch regen.sh run multiple
53# times. Its easier to generate this once here instead.
54do_compile_prepend () {
55 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
56}
57
58do_install(){
59 install -d ${D}/opt/ltp/
60 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
61
62 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
63 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
64}
65
66RDEPENDS_${PN} = "perl e2fsprogs-mke2fs python-core libaio bash gawk expect"
67
68FILES_${PN}-dbg += "\
69 /opt/ltp/runtest/.debug \
70 /opt/ltp/testcases/*/.debug \
71 /opt/ltp/testcases/*/*/.debug \
72 /opt/ltp/testcases/*/*/*/.debug \
73 /opt/ltp/scenario_groups/.debug \
74 /opt/ltp/testscripts/.debug \
75 /opt/ltp/testscripts/open_posix_testsuite/.debug \
76"
77
78FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
79
80FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
81
82# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
83INHIBIT_PACKAGE_STRIP = "1"
84INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
85# However, test_arch_stripped is already stripped, so...
86INSANE_SKIP_${PN} += "already-stripped"
87