blob: 419ed8365e5b7dc6a2c130cfbf9d6b3b95c41fd9 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://pkgconfig_fix.patch \
10 "
11
12# curl likes to set -g0 in CFLAGS, so we stop it
13# from mucking around with debug options
14#
Patrick Williamsf1e5d692016-03-30 15:21:19 -050015SRC_URI += " file://configure_ac.patch \
16 file://CVE-2016-0754.patch \
17 file://CVE-2016-0755.patch"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19SRC_URI[md5sum] = "6b952ca00e5473b16a11f05f06aa8dae"
20SRC_URI[sha256sum] = "1e2541bae6582bb697c0fbae49e1d3e6fad5d05d5aa80dbd6f072e0a44341814"
21
22inherit autotools pkgconfig binconfig multilib_header
23
24PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls zlib"
25PACKAGECONFIG_class-native = "ipv6 ssl zlib"
26PACKAGECONFIG_class-nativesdk = "ipv6 ssl zlib"
27
28PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
29PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
30PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
31PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
32PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
33PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
34PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
35
36EXTRA_OECONF = "--without-libidn \
37 --enable-crypto-auth \
38 --disable-ldap \
39 --disable-ldaps \
40 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
41"
42# see https://lists.yoctoproject.org/pipermail/poky/2013-December/009435.html
43# We should ideally drop ac_cv_sizeof_off_t from site files but until then
44EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)}"
45
46do_install_append() {
47 oe_multilib_header curl/curlbuild.h
48}
49
Patrick Williamsf1e5d692016-03-30 15:21:19 -050050do_install_append_class-target() {
51 # cleanup buildpaths from curl-config
52 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
53}
54
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055PACKAGES =+ "lib${BPN}"
56
57FILES_lib${BPN} = "${libdir}/lib*.so.*"
58RRECOMMENDS_lib${BPN} += "ca-certificates"
59
60BBCLASSEXTEND = "native nativesdk"