blob: 1ee9b862544fcde9c94e287cffbaf75e8da0aaa4 [file] [log] [blame]
Brad Bishop2ad7ce32017-07-09 23:41:49 -04001# To add namespaces and blacklists to the mapper configuration,
2# create a native recipe in your layer, and add it to
3# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
4# Recipes should set one of the variables below.
5# Consult phosphor-mapper.bbclass for additional information.
Ed Tanous9936f862022-09-19 09:13:20 -07006SUMMARY = "Phosphor Mapper Configuration"
7DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
8configuration files to the native /usr/share/phosphor-mapper filesystem."
9HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
12DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
13PR = "r1"
Brad Bishop2ad7ce32017-07-09 23:41:49 -040014
Ed Tanous9936f862022-09-19 09:13:20 -070015inherit phosphor-mapper
16inherit native
Brad Bishop4f045d02018-10-22 20:48:49 -040017
Brad Bishop2ad7ce32017-07-09 23:41:49 -040018do_install() {
19 install -d ${D}/${namespace_dir}
20 install -d ${D}/${interface_dir}
Brad Bishop4f045d02018-10-22 20:48:49 -040021 install -d ${D}/${serviceblacklist_dir}
Brad Bishop2ad7ce32017-07-09 23:41:49 -040022}
Ed Tanous9936f862022-09-19 09:13:20 -070023
24PHOSPHOR_MAPPER_CONFIGS = " \
25 phosphor-dbus-interfaces-mapper-config-native \
26 phosphor-legacy-namespace-mapper-config-native \
27 "
28# Add services to be monitored.
29PHOSPHOR_MAPPER_SERVICE = ""
30# Add interfaces to be monitored.
31PHOSPHOR_MAPPER_INTERFACE = ""
32# Blacklist services from being monitored.
33PHOSPHOR_MAPPER_SERVICE_BLACKLIST = ""