Jorge Cisneros | 8a445a0 | 2020-09-03 21:09:03 +0000 | [diff] [blame] | 1 | do_generate_hpe_image() { |
| 2 | # Add gxp-bootblock to hpe-section |
| 3 | dd bs=1k conv=notrunc seek=64 \ |
| 4 | if=${DEPLOY_DIR_IMAGE}/${HPE_GXP_BOOTBLOCK_IMAGE} \ |
| 5 | of=${DEPLOY_DIR_IMAGE}/hpe-section |
| 6 | } |
| 7 | |
| 8 | do_generate_static_tar() { |
| 9 | |
| 10 | ln -sf ${S}/MANIFEST MANIFEST |
| 11 | ln -sf ${S}/publickey publickey |
| 12 | make_image_links ${OVERLAY_BASETYPE} ${IMAGE_BASETYPE} |
| 13 | |
| 14 | make_signatures image-u-boot image-kernel image-rofs image-rwfs image-section MANIFEST publickey |
| 15 | make_tar_of_images static MANIFEST publickey ${signature_files} |
| 16 | |
| 17 | # Maintain non-standard legacy link. |
| 18 | cd ${IMGDEPLOYDIR} |
| 19 | ln -sf ${IMAGE_NAME}.static.mtd.tar ${IMGDEPLOYDIR}/${MACHINE}-${DATETIME}.tar |
| 20 | } |
| 21 | |