Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 1 | SUMMARY = "Chassis Power Control service for Intel based platforms" |
| 2 | DESCRIPTION = "Chassis Power Control service for Intel based platforms" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Andrew Geissler | f8c00da | 2023-12-07 16:10:31 -0600 | [diff] [blame] | 5 | SRCREV = "b1e34a11f5c64a7c4225fb4cf15ee7f9368cbef4" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https;branch=master" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 11 | |
Jason M. Bills | 26f9276 | 2021-10-26 13:58:15 -0700 | [diff] [blame] | 12 | inherit meson systemd pkgconfig |
Vijay Khemka | a5bc17f | 2020-06-12 16:26:47 -0700 | [diff] [blame] | 13 | inherit obmc-phosphor-dbus-service |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 14 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 15 | SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \ |
Vijay Khemka | 6dfddb4 | 2020-05-21 16:52:57 -0700 | [diff] [blame] | 16 | chassis-system-reset.target" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 17 | DEPENDS += " \ |
| 18 | boost \ |
| 19 | i2c-tools \ |
| 20 | libgpiod \ |
Priyatharshan P | 9691eaa | 2020-06-30 19:57:55 +0530 | [diff] [blame] | 21 | nlohmann-json \ |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 22 | sdbusplus \ |
| 23 | phosphor-logging \ |
| 24 | " |
Patrick Williams | d61a093 | 2021-12-15 21:28:40 -0600 | [diff] [blame] | 25 | FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" |
Andrew Geissler | 0bfc05b | 2023-06-27 12:53:38 -0500 | [diff] [blame] | 26 | |
| 27 | pkg_postinst:${PN}:append() { |
| 28 | mkdir -p $D$systemd_system_unitdir/sysinit.target.wants |
| 29 | for i in ${OBMC_HOST_INSTANCES}; |
| 30 | do |
| 31 | LINK="$D$systemd_system_unitdir/sysinit.target.wants/xyz.openbmc_project.Chassis.Control.Power@${i}.service" |
| 32 | TARGET="../xyz.openbmc_project.Chassis.Control.Power@.service" |
| 33 | ln -s $TARGET $LINK |
| 34 | done |
| 35 | } |
| 36 | |
| 37 | pkg_prerm:${PN}:append() { |
| 38 | for i in ${OBMC_HOST_INSTANCES}; |
| 39 | do |
| 40 | LINK="$D$systemd_system_unitdir/sysinit.target.requires/xyz.openbmc_project.Chassis.Control.Power@${i}.service" |
| 41 | rm $LINK |
| 42 | done |
| 43 | } |