blob: 7f9c460e28a1b606ec77a771132b2b55073d509e [file] [log] [blame]
Brad Bishopc7d1cd92020-09-09 09:57:07 -04001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
2OBMC_CONSOLE_HOST_TTY = "ttyS0"
3
4SRC_URI_remove = "file://${BPN}.conf"
5SRC_URI += "file://server.ttyS0.conf"
6
7do_install_append() {
8 # Remove upstream-provided configuration
9 rm -rf ${D}${sysconfdir}/${BPN}
10
11 # Install the server configuration
12 install -m 0755 -d ${D}${sysconfdir}/${BPN}
13 install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
14
15}