blob: 3f7beaacf23616ce30341d859b5432b341e6a168 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The Suricata Engine is an Open Source Next Generation Intrusion Detection and Prevention Engine"
2
3require suricata.inc
4
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=c70d8d3310941dcdfcd1e02800a1f548"
6
Brad Bishop19323692019-04-05 15:28:33 -04007SRC_URI += " \
Brad Bishop1fdf4aa2019-09-09 14:56:41 -04008 file://volatiles.03_suricata \
Brad Bishop95dbbac2019-12-02 13:55:25 -05009 file://tmpfiles.suricata \
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040010 file://suricata.yaml \
11 file://suricata.service \
12 file://run-ptest \
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040013 "
Brad Bishop19323692019-04-05 15:28:33 -040014
Brad Bishop19323692019-04-05 15:28:33 -040015inherit autotools-brokensep pkgconfig python3-dir systemd ptest
16
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050017CFLAGS += "-D_DEFAULT_SOURCE -fcommon"
Brad Bishop19323692019-04-05 15:28:33 -040018
19CACHED_CONFIGUREVARS = "ac_cv_header_htp_htp_h=yes ac_cv_lib_htp_htp_conn_create=yes \
20 ac_cv_path_HAVE_WGET=no ac_cv_path_HAVE_CURL=no "
21
22EXTRA_OECONF += " --disable-debug \
23 --enable-non-bundled-htp \
24 --disable-gccmarch-native \
25 --disable-suricata-update \
26 "
27
28PACKAGECONFIG ??= "htp jansson file pcre yaml pcap cap-ng net nfnetlink nss nspr"
29PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'unittests', '', d)}"
30
31PACKAGECONFIG[htp] = "--with-libhtp-includes=${STAGING_INCDIR} --with-libhtp-libraries=${STAGING_LIBDIR}, ,libhtp,"
32PACKAGECONFIG[pcre] = "--with-libpcre-includes=${STAGING_INCDIR} --with-libpcre-libraries=${STAGING_LIBDIR}, ,libpcre ,"
33PACKAGECONFIG[yaml] = "--with-libyaml-includes=${STAGING_INCDIR} --with-libyaml-libraries=${STAGING_LIBDIR}, ,libyaml ,"
34PACKAGECONFIG[pcap] = "--with-libpcap-includes=${STAGING_INCDIR} --with-libpcap-libraries=${STAGING_LIBDIR}, ,libpcap ,"
35PACKAGECONFIG[cap-ng] = "--with-libcap_ng-includes=${STAGING_INCDIR} --with-libcap_ng-libraries=${STAGING_LIBDIR}, ,libcap-ng , "
36PACKAGECONFIG[net] = "--with-libnet-includes=${STAGING_INCDIR} --with-libnet-libraries=${STAGING_LIBDIR}, , libnet,"
37PACKAGECONFIG[nfnetlink] = "--with-libnfnetlink-includes=${STAGING_INCDIR} --with-libnfnetlink-libraries=${STAGING_LIBDIR}, ,libnfnetlink ,"
38PACKAGECONFIG[nfq] = "--enable-nfqueue, --disable-nfqueue,libnetfilter-queue,"
39
40PACKAGECONFIG[jansson] = "--with-libjansson-includes=${STAGING_INCDIR} --with-libjansson-libraries=${STAGING_LIBDIR},,jansson, jansson"
41PACKAGECONFIG[file] = ",,file, file"
42PACKAGECONFIG[nss] = "--with-libnss-includes=${STAGING_INCDIR} --with-libnss-libraries=${STAGING_LIBDIR}, nss, nss,"
43PACKAGECONFIG[nspr] = "--with-libnspr-includes=${STAGING_INCDIR} --with-libnspr-libraries=${STAGING_LIBDIR}, nspr, nspr,"
44PACKAGECONFIG[python] = "--enable-python, --disable-python, python3, python3"
45PACKAGECONFIG[unittests] = "--enable-unittests, --disable-unittests,"
46
47export logdir = "${localstatedir}/log"
48
49do_install_append () {
50
51 install -d ${D}${sysconfdir}/suricata
52
53 oe_runmake install-conf DESTDIR=${D}
54
Brad Bishop19323692019-04-05 15:28:33 -040055 oe_runmake install-rules DESTDIR=${D}
56
57 install -d ${D}${sysconfdir}/suricata ${D}${sysconfdir}/default/volatiles
Andrew Geisslerf31b8bd2020-11-30 19:54:56 -060058 install -m 0644 ${WORKDIR}/volatiles.03_suricata ${D}${sysconfdir}/default/volatiles/03_suricata
Brad Bishop19323692019-04-05 15:28:33 -040059
60 install -m 0644 ${S}/threshold.config ${D}${sysconfdir}/suricata
61
Brad Bishop95dbbac2019-12-02 13:55:25 -050062 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
63 install -d ${D}${sysconfdir}/tmpfiles.d
64 install -m 0644 ${WORKDIR}/tmpfiles.suricata ${D}${sysconfdir}/tmpfiles.d/suricata.conf
65
66 install -d ${D}${systemd_unitdir}/system
67 sed -e s:/etc:${sysconfdir}:g \
68 -e s:/var/run:/run:g \
69 -e s:/var:${localstatedir}:g \
70 -e s:/usr/bin:${bindir}:g \
71 -e s:/bin/kill:${base_bindir}/kill:g \
72 -e s:/usr/lib:${libdir}:g \
73 ${WORKDIR}/suricata.service > ${D}${systemd_unitdir}/system/suricata.service
74 fi
Brad Bishop19323692019-04-05 15:28:33 -040075
76 # Remove /var/run as it is created on startup
77 rm -rf ${D}${localstatedir}/run
78
79}
80
81pkg_postinst_ontarget_${PN} () {
Brad Bishop95dbbac2019-12-02 13:55:25 -050082if command -v systemd-tmpfiles >/dev/null; then
83 systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/suricata.conf
84elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
Brad Bishop19323692019-04-05 15:28:33 -040085 ${sysconfdir}/init.d/populate-volatile.sh update
86fi
87}
88
89SYSTEMD_PACKAGES = "${PN}"
90
91PACKAGES =+ "${PN}-socketcontrol"
Brad Bishop95dbbac2019-12-02 13:55:25 -050092FILES_${PN} += "${systemd_unitdir} ${sysconfdir}/tmpfiles.d"
Brad Bishop19323692019-04-05 15:28:33 -040093FILES_${PN}-socketcontrol = "${bindir}/suricatasc ${PYTHON_SITEPACKAGES_DIR}"
94
95CONFFILES_${PN} = "${sysconfdir}/suricata/suricata.yaml"
96
97RDEPENDS_${PN}-python = "python"