Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | # |
| 2 | # This class is used by yocto-check-layer script for additional per-recipe tests |
| 3 | # The first test ensures that the layer has no recipes skipping 'installed-vs-shipped' QA checks |
| 4 | # |
| 5 | |
| 6 | WARN_QA:remove = "installed-vs-shipped" |
| 7 | ERROR_QA:append = " installed-vs-shipped" |
| 8 | |
| 9 | python () { |
| 10 | packages = set((d.getVar('PACKAGES') or '').split()) |
| 11 | for package in packages: |
| 12 | skip = set((d.getVar('INSANE_SKIP') or "").split() + |
| 13 | (d.getVar('INSANE_SKIP:' + package) or "").split()) |
| 14 | if 'installed-vs-shipped' in skip: |
| 15 | oe.qa.handle_error("installed-vs-shipped", 'Package %s is skipping "installed-vs-shipped" QA test.' % package, d) |
| 16 | } |